SCB Global Ltd - Dialogue Cloud | EMEA - NORA | Certain phone numbers not working – Incident details

Dialogue Cloud | EMEA - NORA | Certain phone numbers not working

Resolved
Operational
Started 3 months agoLasted 6 days

Affected

Anywhere365

Partial outage from 12:43 PM to 4:06 PM

Updates
  • Resolved
    Resolved

    Resolved - Dear customers and partners,

    Mitigation steps have been successfully applied and confirmed effective for all affected customers. We are closing this incident as resolved now.

    A Root Cause Analysis (RCA) will be provided through our regular support channels. Customers who are still experiencing any issues, or who applied the resolution steps themselves and would like to receive the RCA, are invited to register a support case.

    We appreciate your patience and cooperation throughout this process.

    SCB-Global.

  • Monitoring
    Monitoring

    Update - We are continuing to monitor for any further issues.
    Oct 28, 2025 - 15:55 UTC

    Monitoring - Dear SCB-Global Customers and Partners,

    We would like to provide an update regarding the previously reported issue affecting UCC Endpoint numbers.

    Scope of Impact: Initially reported for EMEA and NORA regions, the impact has now been confirmed to affect only a very limited number of customers in EMEA.

    Thank you for your collaboration and patience during this time.

    SCB-Global

  • Identified
    Identified

    New incident: Identified


    Dear valued Customer and Partners,


    We would like to inform you of a service incident that may be affecting your experience. Please find the details below:


    User Impact: The main symptom is a number that was assigned to a working UCC no longer answers/completes.


    Scope of Impact: The issue is impacting a limited number of customers, and it affects random endpoints, not necessarily causing a full outage.


    Start Time: 27 October 2025, after 19:15 CET

    Current Status: Identified

    Root Cause: Under investigation


    Next Steps: We are actively supporting impacted customers to restore services. A full root cause analysis will be conducted, and findings will be shared through our Support portal.


    Thank you for your collaboration and patience during this time.